View Single Post
  #1 (permalink)  
Old October 1st, 2003
rockkeys rockkeys is offline
Join Date: September 30th, 2003
Posts: 27
rockkeys is flying high
Default Why does Limewire beta find so few hosts?

Since LimeWire is 'gnutella-compatible', it should be able to share hosts with gnutella-based systems. Yet when I use gnutella (gtk-gnutella on Solaris 8 X86), I find at least 20,000 leaf hosts, and 20,000 ultrapeer hosts every time I use it. Limewire, on the other hand, finds only about 175 hosts maximum, even if I leave it on for hours. Note that both programs are running on the same system, using the same ports, and running under the same user account.

I constantly see LimeWire clients attached to me when I run Gnutella, but I only connect to LimeWire ultrapeers when I run LimeWire. If this is an artifical restriction, it should be removed immediately, because it prevents the user from finding tens of thousands of hosts that they could share files with.

Why does this happen? Could someone explain it to me, please?

No wonder I felt like I was only connected to a small local network. While the systems I am connected to may not be local, they are certainly a small group, compared to what I am used to with gnutella. And this explains why I get so very few results on a search. Since I am connecting to a maximum of less than 1% of the users available, I am finding less than 1% of the possible files that should be found on a gnutella-compatible network.

This can't be right - is there some setting that needs to be manually edited to extend the network to non-LimeWire systems?