Gnutella Forums

Gnutella Forums (http://www.gnutellaforums.com/)
-   Help & Support (http://www.gnutellaforums.com/help-support/)
-   -   any new version for the latest osx (http://www.gnutellaforums.com/help-support/103264-any-new-version-latest-osx.html)

king1964 September 17th, 2015 01:39 PM

any new version for the latest osx
 
hi there any new version for the latest osx for an imac ? seems the old versions don't work with my system .

Lord of the Rings September 17th, 2015 10:36 PM

Do you have Java installed? Check you have Apple's older Java 1.6 installed.
You could try one of the snapshots here. But to answer your question, no there's no newer version other than the snapshots listed.

I have a suspicion the problem might be the Phex app found in the MacOS folder of the Phex package. This was an issue a few years ago. You could try replacing the stub file with this one here called JavaApplicationStubMavericks. Unzip, copy the JavaApplicationStub file into the
phex_3.4.2.x/Phex.app/Contents/MacOS folder & replace the one that's there. ie: find the Phex program package & right-click / control-click to open the package. Then open each folder until you find the MacOS folder & open this. You will find a stub file of same name.
If this still doesn't fix the issue, check you have the older Apple Java 1.6 installed on your system. The newer Oracle Java uses a different system & I don't believe Phex will run with it due to Phex only referencing the older Apple Java positioning on OSX file system.

Apple often change the web page url of older files so if you need the discontinued Apple Java, see here for a 3rd party file-hosting site option.

king1964 September 18th, 2015 01:38 AM

have something to do with ppc is not supported anymore , same problem as with the cabos client .

gtk gnutella will crash after an hour or 2 so seems nothing left as a client for osx ill think .

Lord of the Rings September 18th, 2015 11:37 AM

Yeah I had problems with GTK crashing. AFAIK Phex is not ppc based, it is universal binary and 64-bit which can be checked by opening system profiler & clicking on phex. Although Mountain Lion (ML) suggests it's 32-bit perhaps due to Apple Java being both 32-bit and 64-bit.
At least on ML installing Apple Java fixes both the Phex and Acqlite startup issue.

Did you install Apple Java? If that did not fix things, did you try replacing the stub file?
You could try this as suggested by GregorK a couple years ago.

I'm not using Yosemite so I cannot check it for compatibility.

king1964 September 19th, 2015 04:21 AM

well i wait till there is a new version of gtk , java is installed ill check it later , thank you for your help

Lord of the Rings September 19th, 2015 10:51 PM

Quote:

Originally Posted by king1964 (Post 376809)
... java is installed ill check it later ,

How did things go with your re-checking?

I suspect Phex needs its stub to be re-written so that (1) it checks to see if Oracle JRE is installed & uses that java, or (2) checks if Oracle JDK is installed, or (3) continues with the code that's already there to use Apple's Java.
I tried testing this last year but my poor coding skills failed with it. I'm sure someone more knowledgable could achieve it.

I'm wondering if Phex not running on your system is either due to Apple Java no longer being useable on either your newer Apple hardware or Yosemite.

I'm still very happy with using Snow Leopard though realise I will need to upgrade at some point. I intend to take the plunge at some point over the next 12 months or so, though I simply don't like some of the changes which greatly affect my day to day use of the system. The changes will notably slow down my usual methodical way of using the mac. I have an alternate startup drive I might test out first. Up to now I've been testing ML & Mavericks on a VM.

Quote:

Originally Posted by king1964 (Post 376809)
well i wait till there is a new version of gtk ,

my GTK has been crashing since beginning of last year. Sometimes I'm lucky with it staying open for an hour or two.

There's always WireShare to use, which is the continuation of LimeWire Pirate Edition. WireShare has been re-written to run with either Oracle or Apple Java. But being a Phex user it's probably not your preferred type of program. And WireShare is not as memory or CPU efficient as Phex.

king1964 September 20th, 2015 02:42 PM

ill think because apple don't support PowerPC programs anymore that is the message on my screen , same message as with cabos i believe .

king1964 September 20th, 2015 02:46 PM

that stub file , i cannot find for some reason , seems the link is not working

Lord of the Rings September 22nd, 2015 01:48 AM

I took a plunge & installed Yosemite on my alternate startup drive. Inititally trying to open Phex it asked to install Apple Java. There's apparently a 2015 update to cater for Yosemite https://support.apple.com/kb/DL1572?locale=en_US. Phex still would not open. So I tried opening an alternative Phex version which I suspect I had previously changed the stub file of for Mavericks. Phex opened fine. I don't know if this will fix the issue for you but try the one I uploaded called Phex_for_Yosemite.zip at MediaFire.

I didn't have any problems opening Acqlite (almost same as Cabos) after the Apple Java update.

king1964 September 22nd, 2015 05:57 AM

thank you , acqlite don't have problems also for my imac , except the connection , cabos does have the same problem as phex , but since yesterday my gtk-gnutella is already 20 hours online without crashing , seems since i download and upload i do not have an crash anymore , i also lower the connections ( dunno if this was the reason ) , i am off work in 2 days will check your phex file then .


All times are GMT -7. The time now is 09:02 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.0 ©2011, Crawlability, Inc.

Copyright 2015 Gnutella Forums.
All Rights Reserved.