Gnutella Forums

Gnutella Forums (http://www.gnutellaforums.com/)
-   Help & Support (http://www.gnutellaforums.com/help-support/)
-   -   MacOSX Java version workaround (http://www.gnutellaforums.com/help-support/104154-macosx-java-version-workaround.html)

Lord of the Rings July 9th, 2018 08:55 PM

MacOSX Java version workaround
 
1 Attachment(s)
The last official release of Phex for MacOSX uses the java 5 or 6 stub within the app. This of course is incompatible with later version java. The java stub could also be problematic running within different OSX versions which may use a different java 6 variation.

Running Phex under any version of Java:

One solution to the Java 5 or 6 Stub problem is to use the: 3.4.2.163 universal version. This version will call whichever version of Java exists on the system including Java 7 or 8 or probable later java version. Only inconvenience is opening the program via the phex.jar file within the program lib folder.

Attachment 6953


(Just my thoughts: Phex really needs to be re-compiled on OSX with a newer java (JDK) version with backward java version compatibility for creating the starter app. Alternative is for the app to simply point to the phex.java file in lib (renamed Resources to match OSX application protocol.) Creating the app pointer can potentially be done manually with help of Unix perm's & commands.)


All times are GMT -7. The time now is 08:40 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.0 ©2011, Crawlability, Inc.

Copyright 2015 Gnutella Forums.
All Rights Reserved.