Gnutella Forums

Gnutella Forums (http://www.gnutellaforums.com/)
-   LimeWire Beta Archives (http://www.gnutellaforums.com/limewire-beta-archives/)
-   -   4.9.28 Disconnected (http://www.gnutellaforums.com/limewire-beta-archives/44120-4-9-28-disconnected.html)

fabion August 26th, 2005 07:37 AM

4.9.28 Disconnected
 
quote:
--------------------------------------------------------------------------------
Your machine does not appear to have an active Internet connection or
a firewall is blocking LimeWire from accessing the internet. LimeWire will automatically keep trying to connect you to the network unless you select "Disconnect" from the File menu.
--------------------------------------------------------------------------------
This is the message I had this morning on checking LimeWire 4.9.28 Pro.

Upon further checking it was actually disconnected from the internet. Although the machine still had an active connection. Viewing a sample bug report confirmed LimeWire had no active connection also.

I also had the firewall icon present for the 1st time. In files I clicked connect, and it connected as a leaf. The firewall icon also disappeared.

LimeWire was running as a UP with 32 P and 20 L upon retiring for the night.

One note from my usual operation. I normally close all searches before retiring for the night. I had left 2 open.

I will attempt to duplicate this problem and get a stack trace for you. unless you have have a newer version out again.

Grandpa August 26th, 2005 09:13 AM

After running all night in UP port forward when I checked in morning still running 32 pears 14 leaves apparently did not disconnect during the night showed 10 host connected for 11 hrs. I left one search open for night it was idle in AM clicked resume went to awaiting sources this is a rare file. 10 ul 10 in Q.

fabion are you able to connect as a UP in UPnP or do you have to manually port forward?. I was just wondering I have been doing some testing and the only way so far with 4.9.24 haven't tested .28 yet that LW has disconnected is if I am running in UPnP with router set at default settings. Or manual port forwarding and say in the manual box put 6346 and listen on port 6348. I am currently running on manual 6348 listening on 6348 working fine. I have also found that I can not run in UPnP mode for more than 2 or 3 hrs without having to reset my router. But I haven't tested it with 4.9.28 yet don't know if it is still a problem.

fabion August 26th, 2005 10:10 AM

Hi Grandpa

I haven't had a problem until now. I have LW configured for UPnP and have been able to connect as such. Normally I have 32 P and 30 L connected, unless I switch to leaf by disabling UP capabilities.

Here more recently 4.9.27 and this version seems to take about an hour or so to get fully connected, and then my peers are normally 30 - 32, but the leaves fluctuate between 17 to 30.

Seems I drop 1 or 2 peers and up to 10 leaves, when doing searches.

I have received that warning box in the past, but LimeWire was still actually connected, and appeared to be coming out of idle mode. This was the 1st time it was actually disconnected, and had the firewall brick icon showing.

It hasn't duplicated yet.

Grandpa August 26th, 2005 10:58 AM

[QUOTE]Your machine does not appear to have an active Internet connection or
a firewall is blocking LimeWire from accessing the Internet. LimeWire will automatically keep trying to connect you to the network unless you select "Disconnect" from the File menu.

Got the message above. I was running in port Forward as UP went to file/disconnect manually disconnected. LimeWire then tried to connect for about a minuet then the message pooped up LimeWire continued searching for a connection and connected after a minuet as a Leaf so it appeared it did what it was suppose to.

fabion

I am trying to figure out why you can connect as a UP in UPnP mode and I can't. I do not have UP disabled so I am wondering what your connection is. I have cable test at 650 to 700kb down and 45kb up when running in port forward mode. But when running in UPnP mode it test at between 28 and 50kb down and 20 and 35kb but I can still DL on LW at 600+ these test were done while I was not DL anything and UL 5 at 30kb all things being equal. I know that LW is having an affect on my router but I still haven't figured out how to stop it from happening. But I am going to keep trying hell I might get lucky some day. Also are you running through a router.

fabion August 26th, 2005 11:20 AM

Grandpa

I am running a dsl modem/router. My machine has a 1 Gb ethernet card attached to the modem/router by an ethernet cable. Speeds tests from various sources show a consistent T-3 connection speed with no applications running, but the browser.

Grandpa August 26th, 2005 12:01 PM

fabion

I'm Jealous but my suspicions are confirmed. I am now guessing that LW is doing it's job in detecting connection speed and determining when to connect as UP. I think There is a little bug in LW that is allowing to over load my router in UPnP mode with cable. I know if I run direct from my modem it does not happen but UPnP is not active in this mode. So I guess I will just do a little more playing with router and LW settings pull out a little more hair a see if I can find a fix for UPnP.

Thanks for your reply

Grandpa August 26th, 2005 01:56 PM

This is how I found LW when I returned fro town about 2 hrs after starting UPnP mode. I was able to reconnect LW by file/connect did not have to restart no connection message.
Stack Trace
[Fatal Error] :1:186: An invalid XML character (Unicode: 0x3) was found in the v
alue of attribute "album" and element is "audio".
[Fatal Error] :1:369: XML document structures must start and end within the same
entity.

deacon72 August 29th, 2005 03:35 AM

Been busy this weekend so I tried to leave LimeWire run.

Found the same disconnect notice Fabion did for the past several mornings and evenings. Downloads seemed to be continuing, but could not reactivate my searches until I connected again. My downloads had gone to 3 @ 0 kb in the best scenario. Uploads were stilll at 19 @ 34 kb. (all approximate) My TCP and UDP settings are CORRECT and I have sufficient PORTSenabled. My UPnP is enabled. MY settings here on my end and my understanding of this program are better now than it was back with 4.8.1.

Conclusion: somewhere in the code there is a glitch.This glitch has been present in the past several, if not most releases, of the 4.9 series, but is not in 4.8.1. I have 2 machines on this home network. One is running 4.8.1 and has NO disconnect issues. This one is running 4.9.28 and as stated has disconnect issues and has had since several weeks ago. There are no more tweakings that I can do or that I can do to make LimeWire work. Imagine the consternation of the average user and the ramifications if this disconnect issue is not resolved. As I sit here typing I was disconnected, again. The other computer is still connected.

et voilą August 29th, 2005 04:48 AM

Well that problem is limited to those who have XP SP2, because MS limited the number of connections. If you are tired of waiting for a fix, patch your system with http://mitglied.lycos.de/lvllord/download-mirror.htm

Ciao

fabion August 29th, 2005 06:33 AM

Hi et voilą

I do have that patch installed. http://forums.gnutelliums.com/showth...threadid=42463

But I have concluded it has something to do with the latest M$ updates not sure what. They came out a couple weeks ago. I have had a few problems with other applications as well, but I have figured out and corrected those problems.

But this is 1st I've noticed or had problems with LimeWire staying connected, when left to continue on it's own for an extended period of time of more than an hour.


All times are GMT -7. The time now is 03:20 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.0 ©2011, Crawlability, Inc.

Copyright © 2015 Gnutella Forums.
All Rights Reserved.