Gnutella Forums

Gnutella Forums (https://www.gnutellaforums.com/)
-   General Discussion (https://www.gnutellaforums.com/general-discussion/)
-   -   Java for Phex in OSX (https://www.gnutellaforums.com/general-discussion/57407-java-phex-osx.html)

Lord of the Rings June 17th, 2006 10:35 AM

Java for Phex in OSX
 
I've been using Phex 2.6.4
I'm operating in OSX 10.4.6 with Java 1.5 forced as the 1st preference Java for all applications. Yet I've just noticed Phex is using Java 1.4.2
I'd have thought Java 1.5 would be preferential. Do the newer Phex versions allow for Java 1.5 on OSX?
Is a high no. of threads normal for Phex? Last time I noticed around 450 or so I think it was (after a few days.)

Also I notice the firewall icon takes about 10 mins to turn off. I have a port forwarded for Phex. I was so concerned recently I re-port forwarded thinking I hadn't port forwarded correctly when I previously used Phex (2-3 mths ago.) Why does Phex take so long to see that the listening port is already open for it.

BTW it would be nice if the window settings/positioning were retained for each time we re-opened Phex.

Edit: I haven't downlded anything this time & threads is 30 odd after about 4 hours.

GregorK June 18th, 2006 03:47 AM

Well not sure why Phex is using 1.4.2 on OSX, Java 1.5 would be much preferred. Specially since OSX is still the only environment where Java 1.5 is not the dominating Java VM used. So if you find a solution why 1.4 is used I would be very interested about it.

A high number of threads is usuall for Phex. Maybe after a few days the number growed a bit too high because of unknown leaks but if you hold many connections, downloads and uploads you can expect numbers well over 150 threads.

The firewall icon is buggy in Phex, it is a know problem since some time. But since its only a visuall problem not much effort is made to fix this yet. You can be sure even with firewall icon Phex is able to accept incomming connections and upload requests when your port is forwarded correctly.

The window position and size should be retained, also the width of table columns. In case it is not working for you, it might be a platform specific problem somewhere.

Gregor

et voilą June 18th, 2006 05:50 AM

Well you have to change a line in info.plist found in Phex.app->Contents
At the line
<string>1.4*</string>
change that line to
<string>1.4+</string>

Phex should now use default JVM.

LODR, you can open and save the file in TextEdit

GregorK, can you change that in Phex Os x project?

Ciao

GregorK June 18th, 2006 06:23 AM

Great info... I must admit I'm a noob in OSX ;)
But I changed it in the osx build process, it should be in the next release.

Lord of the Rings June 18th, 2006 12:06 PM

Thanks et voilà it worked like a treat. I'm using Phex 2.8.4_93, I must have opened the earlier version by mistake yesterday. I thought it looked a little different to the previous occasion. :D It seems to work a little better than 2.6.4 also re: search results, though that might just have been the timing, peers, etc..

GregorK October 15th, 2006 03:08 AM

2.8.10 should run fin on OSX with Java 1.4.2. Can you try to raise the memory Java is allowed to use with Phex. I think Arne was having similar issues back when he used OSX.
Try to start Phex like this:
java -Xmx256m -jar phex.jar
Which will allows 256MB RAM to be used for Java heap space...
If that would be too much for your system, anything above 64 will give Java more maximum heap space then the default setting.

Lord of the Rings October 23rd, 2006 12:49 AM

I ran 2.8.10 in OS 10.3.9 (Java 1.4.2) without crash but it didn't connect .... needed to find out the port I opened for it in router so I had to reboot into 10.4.8 Will recheck soon. 1st time I had run it in that installation of 10.3.9

GregorK October 23rd, 2006 12:52 AM

Well this is a Java only way of telling that you allow the Java VM to allocate more Heap memory... its not Mac specific.
Sometimes when the heap fills up close to its limits the Java VM has to do a lot cleanup processing and can become slow... not sure if this is a memory leak or just a higher heap usage in the latest release. Apperently VMs on different plattforms can deal more or less good with this situation.

The crash you posted is most likely not Phex related, most crashes are due to Java bug or incompatibilities with driver, os libraries or these things..

Lord of the Rings October 23rd, 2006 01:10 AM

AFAIK the Java for OSX is not that efficient. Memory leaks or threads not giving up memory used. That was probably more evident in Java 1.4.2 for mac. Just my 2 cents. Not sure how that should apply to launching however.

Lord of the Rings October 23rd, 2006 02:20 AM

For what it's worth ... I rebooted into 10.3.9 & changed to appropriate port for Phex to match router setting, & bingo ... immediate connection ... no firewall issue. And opened up nicely & behaved nicely.

I then rebooted into 10.4.8 (with Java 1.5) & bingo, Phex immediately connected "healthily" with no firewall icon issue. Nice set of connections too for both OS's but even a couple better now. That's better than the previous versions which were slowish to wake up to an open port. So far thread use is consistent at 58-59 & VM is also consistent at 430-40 MB. Good version!!! :) Will see how it behaves after days of use. A good long busy session to test it out. :D :tease:

Maybe's OAH's Apple G3 architecture is getting a bit 'long in the tooth' to handle the newer ...


All times are GMT -7. The time now is 09:39 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.0 ©2011, Crawlability, Inc.

Copyright © 2020 Gnutella Forums.
All Rights Reserved.