Gnutella Forums

Gnutella Forums (http://www.gnutellaforums.com/)
-   Gnucleus (Windows) (http://www.gnutellaforums.com/gnucleus-windows/)
-   -   Updated Connection Caches for Gnucleus! (http://www.gnutellaforums.com/gnucleus-windows/89479-updated-connection-caches-gnucleus.html)

File_Girl71 December 15th, 2008 05:42 AM

Updated Connection Caches for Gnucleus!
 
Here is the Updated Connection Caches For Gnucleus! Should make you connect to Gnutella and G2 quit quick....Hope it can helpe you all with connection probleme!:rolleyes_2:

Download it from either of these 3 host sites:

(i) Gnucleus 2 Connect Cache August 2013.zip via 4Shared . . . . Gnucleus Settings installer.zip via 4Shared (includes Connection file)

(ii) * To choose from a Mirror Download site download folder, find all Gnucleus connection cache installers via FileCloud "here" (disable your browser's AdBlock to use the iFileIt site. Sample image download instructions using FW4 as an example.)

(iii) Or alternatively Mirror Site 3 (MediaFire)


Edit Feb 2012 by Lotr: Hijacked File_Girl71's post whilst she was asleep "lol"

Updated Connection data installers for both of Gnucleus 1.8 and Gnucleus 2.x versions. Selection of Gnutella and G2 hosts were based on those that stayed connected to Gnucleus for a considerable period of hours or days. This is still a maturing host list so I will update it now and again. Initially within the week, then every 2 to 4 weeks. The gnutella hosts include those that happily stayed connected to Gnucleus 1.8 for many hours or days. My Gnucleus 1.8 connects to 5 gnutella peers. So if hosts were happy to connect with Gnucleus 1.8, they should be fine with Gnucleus 2. I've been running versions 1.8, 2.0.9 and 2.2. I also concentrated on static host ID's. Thus, the connection data should be good for a considerable period of time for both the gnutella and G2 networks.

Edit Aug 2013 by Lotr: Hijacked post again: Selection of hosts for new cache based on some of the decent of other gnutella caches I work with. Gnucleus v.1 Ultracache was momentarily made 'read only' but in retrospect seemed to get odd results so I have reversed this. For v.2, G2 host cache was not fully changed, since many were still very active and of the best decent reliable peers to hope for. (Most if not all of them ShareAza peers.)

Connection installers now include optional blocklists for either Gnucleus v.1 or v.2.

A settings installer option for persons who download Gnucleus from SourceForge instead, but includes both Connection & optional blocklist files.
.

Lord of the Rings December 15th, 2008 06:21 AM

That's great, if it works for everyone. :)

Edit: since File_Girl changed the host site, Click the Request Download Ticket, you wait the 20 or 30 seconds on following page then press the Download link when it appears.

andrewwan1980 December 15th, 2008 04:26 PM

Yes, don't be fooled by the MASSIVE RED download icon... that's advertisement for something totally different.

You will find the Request Download Ticket link at top left corner of the page.

I just tried it with 1.8.6.0 and it works. Just connected to 3 UltraPeer and hoping to connect to more.

QUESTION: what ports should I portfoward/open to get fastest connection?

File_Girl71 December 21st, 2008 05:51 AM

you could try this one 6346 or 6348,they are native Gnutella port as i know,you could also try a randome one to like 3349....:laugh_2:

Lord of the Rings February 19th, 2012 07:37 AM

This only applies to Gnucleus 1.8 users who might be having connection problems. This does not apply to any of the Gnucleus 2 versions because their Gnucleus connection file is a little different.

For anybody using Gnucleus 1.8, you can simply use the data from the general gnutella connection file. This is a kind of a quick fix approach. After downloading, you will need to change the name of the file from gnutella.net to GnuCache.net and then put this file into the top level of your Gnucleus program folder. Gnucleus will probably only use one of any of these hosts to connect, but will then use its ability to find other hosts once connected. Upon Gnucleus 1.8 closing, it will reduce the list to 200 hosts which is the maximum it is set to save. Best to keep Gnucleus 1.8 running as long as possible so it collects a reasonable list of reliable peers to connect to for next time.


The general connection file download link: gnutella.net.
If you're not registered at 4Shared & don't want to register, use this link : Rapidshare download for Gnutelle.net file (Remember to change the file's name from gnutella.net to GnuCache.net)

Lord of the Rings February 23rd, 2012 09:23 AM

*Bump*
I have attached up-to-date connection installers for Gnucleus. Be sure to choose the right installer for the same version of Gnucleus you are using. Gnucleus 2.0.1.0, 2.0.9.0 and 2.2.0.0 should all use the Gnucleus 2 connection installer.

Gnucleus 1.8 or any other version 1.x should use the Gnucleus 1.8 connection installer. :)

If you are using Gnucleus 1.8, when you get connected do a search and this will help you keep your peers connected. ie: keep the search open. Gnucleus has an idle mode where it drops peer connections each within 10-15 minutes of the other if it is not doing anything, down to one. I have only seen one other Gnutella client do this, but that's after about an hour of being idle.

Also for Gnucleus 1.8 only, whilst Gnucleus is closed, you could open the GnuConfig.ini file and change the connect detail to something like this (unless you wish to run in Ultrapeer mode):
Code:

[Connect]
AutoConnect=1
MinConnects=4
MaxConnects=6
FriendsMin=0
LeafModeConnects=5


smaragdus February 23rd, 2012 07:44 PM

Hi there,

I am not a regular Gnutella networks user, from time to time I used ShareAza but since it had severe problems hashing big external hard drives (1GB), I decided to switch to Gnucleus although I knew it had been an abandonware for quite a long time (I simply liked its clean interface). I installed Gnucleus version 2.2.0.0 but it could not connect. Then I searched this forum, found FileGirl71's Gnucleus 2 Connect Cache Feb 2012.zip, downloaded and isntalled it, but to no avail, Gnucleus 2.2.0.0 still could not connect. Then I downloaded gnutella.net, renamed it to gnucache.net and substituted the original file (although Lord of the Rings has warned that this works only for version 1.8 of Gnucleus). Gnucleus finally managed to connect but connection seems very shaky and thin. Below I will add a screen-shot link for its connections:

http://i43.tinypic.com/xgckr8.png

Is this a normal connection for Gnucleus? Is there a way to make Gnucleus work properly or its support for Gnutella networks is terribly outdated?

Please excuse me for my ignorance. I will appreciate any kind of advice and tips.

By the way Gnucleus's built-in browser does not work for me either.

One last question- should I uninstall Gnucleus before I install FileGirl71's special build or it can be installed upon the original Gnucleus?

Thanks in advance.

Lord of the Rings February 23rd, 2012 08:00 PM

2 Attachment(s)
In my opinion, it's probably best to uninstall the other first if you intend to install a different version. You can do that via the Start menu > Programs > Gnucleus > Uninstall.

But first, before you panic. Did you put Gnucleus in your firewall exceptions? Go to Control Panel, open up the firewall, click on Exceptions tab, then the Add Program button or similar depending on which firewall software you are using. And choose Gnucleus to add.

To my knowledge, Gnucleus does not have UPnP support. Thus if you are using a NAT modem or router, then you should port forward a port for it such as 6346 or 6348.

If you earlier ran any other file-sharing program using the same ports as Gnucleus during the same boot session, then you should reboot your computer. Routers will reserve a port per program per boot session.

In general, with exception of initial opening of Gnucleus, I found Gnucleus v.2 only connected to one or two peers for the gnutella network, and two hosts for G2. Search results were quite ok though. But you do need to add your own filter words of course. Gnutella connections and G2 connections are shown in separate windows, you need to check which option you wish to see at the time. If you use the Browse Network from Tools menu, then you can see both in detail at once.

The browser works on my v.2.0.9 (the others are closed down at moment.) I am guessing yours is blocked via a firewall of some description. Perhaps some other kind of security software? The fact the browser is not working for you highly suggests a security software on your computer is blocking Gnucleus's full access.

Browser (from View menu):
Attachment 5831

One thing about File_Girl's Gnucleus 2 versions is she included an updated built-in GWeb-Cache, and a basic block-list and clean installer.

Important note about Gnucleus version 2, do not expect to see a window full of gnutella connections. Expect to see two G2 connections (click the G2 option to see the G2 connections) and one or more gnutella connections. I suspect it was designed that way. I found version 2 only connected to multiple gnutella peers when it first started up. File_Girl might be able to correct me on that. :)

To see your connections in detail, go to the Tools menu, choose Browse Network.

Browse Network Connections (from Tools menu):
Attachment 5833
(Host addresses changed to protect privacy.)

Lord of the Rings February 24th, 2012 07:08 AM

1 Attachment(s)
I used the connection installer for Windows 7 after I booted the system up (Win 7 had been closed down for about 10 hours.) Gnucleus took 3-5 seconds to connect to each of 5 hosts so I had 5 gnutella connections within 20-25 seconds. G2 also obtained 2 connections very quickly.

The connection installer worked for me for Gnucleus 2. So I am convinced your problem with connecting is due to security software or router NAT firewall or both. Or a clash of ports being used with another program which is why I earlier suggested a reboot (for example if both ShareAza and Gnucleus had been using port 6346/6348 since the last computer boot up.) But the Browser not working suggests security software is your problem.

Attachment 5985 (click thumbnail to see larger view, click again to see in its own window)

Sample image shows a full 5 connections for Gnutella Network after starting up. This will drop back after a time.
Two connections for G2 always remains constant.

Host addresses in the sample image were changed to protect privacy.
And yes I agree, Gnucleus can hash files very quickly and also since you can adapt how much cpu energy is put toward the process. :) Even the default seemed very good in comparison to how I remember ShareAza hashing files, but I have not used ShareAza for a couple of years. I had a security issue with ShareAza sharing files not selected to share so I stopped using it (These were private files on a different drive/network which ShareAza should never even have had access to.)

Lord of the Rings August 3rd, 2013 04:28 AM

Gnucleus has not been forgotten. :D Put together a nice highly effective connection fix that connects in a flash for both G1 & G2. But I will not be releasing it for a few more days. I am combining it with a blocklist to help stamp out those 'orrible ugly BOT spammers. I was seeing spammers I first saw in early March (quite a few actually from March), so I am still in the process of putting together an effective blocklist as an option in the connection installer. I will also re-do the settings for Gnucleus versions 1 and 2 for greater efficiency. I first started the blocklist in December last year and realised it was going to be very long-winded and take months to finish. So I took a break until now. It will be an on-going process for a while but will release a preliminary version soon. The new installer will include both Gnucleus V.1 + 2 install options instead of being separate installers. I certainly noticed the lack of connection to spammer clients after testing the combo connect & blocklist a multitude of times.

Yeah, no updates since March 2012, no wonder my Gnucleus v.1 & 2 were slowish to connect. Although I did do a minor December update for Gnucleus v.1. I tested Gnucleus out on Win 8. I will explain my findings later. Main finding is the Gnucleus program compatibility mode needs to be set to at least Win XP SP3 or settings are not saved and connection difficult. But SP2 might be better, not sure yet. This will also apply to Vista & Win 7 as I found settings were not saving completely in Win 7 almost 2 years ago. Also added a more extended search filter list for first time users. Anyway, this will be released within the next week or so. If the dates of the installers in the first post above are still Feb. 2012 then I have not yet updated the files. I will make sure I do both changes simultaneously.

An important note: if you are using or potentially thinking about using Gnucleus, then you should port forward your modem/router. Gnucleus does not have UPnP support or NAT traversal/port-mapping abilities. One option if your router has the ability is to set Gnucleus or its port as a Special App exception in the NAT rules of your router. This seems to work well. You would never become an Ultrapeer under normal circumstances otherwise and possibly struggle with connections.

If I am to do proper spammer/hostile host hunting then I may need to remove the Gnucleus blocklist to know if hosts are still using same ip's or not. :rip::toilet:


I really like the ability to split windows into their own space in Gnucleus. No other Gnutella app has that ability after all these years. Heck 1.8 had it as far back as 2002. BTW chat for Gnucleus is via IRC. I will update the installers for those that don't posses the links to the rooms. Even v.1.8 uses IRC for these rooms which are still used. Not as crowded as previously I'm sure, but you can always custom add your own rooms at your choosing if you know of others.


All times are GMT -7. The time now is 07:25 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.0 ©2011, Crawlability, Inc.

Copyright 2020 Gnutella Forums.
All Rights Reserved.