Gnutella Forums

Gnutella Forums (https://www.gnutellaforums.com/)
-   Gtk-Gnutella (Linux/Unix/Mac OSX/Windows) (https://www.gnutellaforums.com/gtk-gnutella-linux-unix-mac-osx-windows/)
-   -   d-link router config (https://www.gnutellaforums.com/gtk-gnutella-linux-unix-mac-osx-windows/99563-d-link-router-config.html)

frankzen December 12th, 2011 08:20 AM

d-link router config
 
I am running Debian Sid with the latest Gnutella - the router is a D-Link Ebr2310. I have forwarded ports 6346 for my computer IP. But when I run Gnutella is still says I am firewalled and won't see...etc. etc" .


What have I done wrong ?? :mad2:

Thanks

Lord of the Rings December 12th, 2011 08:26 AM

Did you set up a Static ip before you did the port forwarding? That must be the very first thing you do, else you need to cancel your port forward rules & repeat.
From memory with D-Link, you need to reboot the router to both save the settings properly and to get them operational also, I might be wrong. Did you do that? Rebooting the computer may also help. Just a few suggestions to try.
I had a D-Link some years ago.

Do you use a software firewall also? If yes, add the program to both it's UDP & TCP exceptions. Be sure it's both. ;) OH .. and also for the router. Many gnutella clients use both tcp & udp for their communications. I think in the case of D-Link, you choose ALL (ie: both tcp & udp.) It's been a while since I used my d-link (it was only adsl1.)

Rebooting both the router and the computer should do the trick if you did port forwarding correctly. :) Rebooting the computer refreshes the memory & the external ip address, etc.

For setting up a static ip address for Debian, not sure these will help:

http://www.techiecorner.com/486/how-...-ip-in-debian/

http://www.debian-administration.org/articles/254

http://wiki.debian.org/NetworkConfiguration

http://www.nflug.org/pipermail/nflug...ly/021014.html

http://www.cyberciti.b iz/faq/linux-configure-a-static-ip-address-tutorial/ (remove the blank space)

frankzen December 12th, 2011 08:48 AM

No I didn't but I get my IP via DHCP, so it could change (although it hasn't in along time).

The problem now ( to change boats in mid-stream) is it started to work after I changed the Guntella listen port to the one I had forwarded. HOWEVER my wife's Windows XP machine also on the router could no longer connect to the internet after it started to work on my machine. Weird because I made no changes to the port forwarding screen for her machine??? Rebooting her machine (My Gawd Windows takes a long time to boot) did not solve the problem.

I don't use a software firewell.

Lord of the Rings December 12th, 2011 08:51 AM

Make sure you do not port forward any of the same ports as your wife uses. Each application on each computer must be using a different port.

She probably needs to reboot. Sorry, but when changing router settings, it's one of those things .. reboots usually fix it. Hopefully lol

Well .. if you did not set up a static ip address, the problem is, next time you restart your computer or router or the ip changes, the ip will change & you will not be connecting so luckily at a guess with your program.

frankzen December 12th, 2011 10:29 AM

I don't see why...her computer has different address in the router. I did reboot her computer but she still couldn't connect, so I had to disable port forwarding for my computer. Another strange thing --- the router says her computer has 3 addresses open to the WAN...mine only one.

Lord of the Rings December 12th, 2011 11:04 AM

hmm .. which is the main computer connecting to the router?
Let's give an example. Normally, the router will have an address such as:
192.198.1.1
Next computer first on network might have an address such as:
192.198.1.2
And next computer an address such as:
192.198.1.3, etc.
If she has more than one account on her computer then it may count as a different number for each account. (Or if she has peripheral devices connected such as iphone or ipod etc.)

And yes, her computer MUST have a different address to yours. Each computer on the network must have a different address with the router as the lowest denominator ip address.
If you had 5 computers connected to the router, then the fifth computer might have an address such as 192.198.1.6

If you were both connecting using same address, then yes that would cause a connection problem. On an apple mac I think the network ip address is automatically allocated. I suspect same is true for Windows. For Linux, I have no idea. I did read in one of the above links, you do actually need to manually edit the connection files. Perhaps .. an alternative might be to set her computer up to connect to the router first? With Windows XP might make it easier. But you may still need to manually edit a connection file .. I don't know. I am totally Linux dumb. lol :D

Networking around a router can be confusing, also depending on the router software, and I guess also depending on the computer systems involved, since Linux does not have such ready made assistance software for it that comes with the router software support etc.

From my understanding, as long as all the network connections each have a separate connection ip address that comes after the router's address, they may even start from 192.198.1.50 for the first computer in the network for example. Usually the router will have a default internal ip address such as 192.198.1.1. This can be changed, but not recommended (unless clashing with a secondary router of sorts.)

ram February 3rd, 2012 03:58 AM

Check the port or rely on UPnP / NAT-PMP
 
Quote:

Originally Posted by frankzen (Post 366583)
I am running Debian Sid with the latest Gnutella - the router is a D-Link Ebr2310. I have forwarded ports 6346 for my computer IP. But when I run Gnutella is still says I am firewalled and won't see...etc. etc" .

Firstly you need to make sure 6346 is indeed the port that gtk-gnutella will be listening to. By default, gtk-gnutella uses a random port initially. You can view the listening port in the Preferences / Network configuration tab. This is the port you need to forward (once randomly selected, it will remain stable until you change it).

Secondly, you need to know that gtk-gnutella supports both UPnP and NAT-PMP. Therefore, if you router has UPnP or NAT-PMP support, it will be much easier to enable that and let gtk-gnutella automatically install the required port mappings.


All times are GMT -7. The time now is 01:29 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.0 ©2011, Crawlability, Inc.

Copyright 2020 Gnutella Forums.
All Rights Reserved.