Gnutella Forums

Gnutella Forums (
-   LimeWire Beta Archives (
-   -   disabling Leaf mode? (

sdsalsero December 22nd, 2001 11:53 AM

disabling Leaf mode?
I tried the suggestion to add the following to my Limewire.props file:

It eventually worked, but there's been some strangeness along the way:
1. Even though I restarted in Client mode (and not Leaf mode), I only connected to one host. I was configured for 4 hosts, and I have a T1 line.
2. Within 24 hours, I had been promoted to an Ultrapeer (yeah!), so that part works. Before, it took me 3 days to be promoted.
3. Now, I'm an Ultrapeer, but when I go to look at my Limewire.props file, it shows EVER_SUPERNODE_CAPABLE=false, MAX_UPLOADS=8 and UPLOADS_PER_PERSON=3, none of which is correct or matchs what the GUI/Options reports.

Is there a known bug where forcing Supernode still doesn't allow you to connect to all 4 hosts? It appears to act like a Leaf, i.e. only one host.

And why doesn't the limewire.props file match the Options screen?
- Tony

Unregistered December 22nd, 2001 01:02 PM

I'm just making sure of this....
Are you a high-speed user? Modem users should not become UltraPeers. I'm just checking..... if you are indeed a high-speed user, you've found a bug or oddity of some sort.


sdsalsero December 23rd, 2001 03:14 PM

I have a T1
Yes, I'm a high-bandwidth user -- I have a T1.
And, Yes, I think I have found a bug/oddity or two...

crohrs December 26th, 2001 10:31 AM

It sounds like you may have edited a limewire.props file from another version. In the latest version, the default file is in
"c:\Program Files\LimeWire\2.0.2", but this changes if you changed the directory on install. Also, be sure you edited the limewire.props file when no LimeWire was running.

Unregistered December 26th, 2001 03:55 PM

Ok, so let me get this straight. I also have a t1 and I keep getting logged on as a "client". Sometimes I have to wait 10 minutes just to get 1 host and my searches come back with nothing. If I start version 1.7c, I can do the same search and get back 300-400 returns. I tried to edit the props file, but whenever I restart Limewire 2.0.2, it seems to rewrite the file and returns it to its original configuration.

What's the deal or should I wait a bit and stick with 1.7c?

crohrs December 27th, 2001 07:13 AM

Just because you have a T1 doesn't mean you'll become an ultrapeer. You might be firewalled, for example. Or you might have found another ultrapeer that doesn't have enough leaves, turning you into a leaf. LimeWire tries to be a leaf whenever possible.

What we're hearing is that some people get less than desirable search results in leaf mode. You can disable this if you really want by modifying limewire.props as described above.

sdsalsero December 27th, 2001 05:58 PM

Leaf or Client to an Ultrapeer
I think the problem is two-fold:

1st. Ultrapeers don't correctly forward upload requests. I say this because I have a lot of files shared and my upload slots are usually full, but until I get promoted to Ultrapeer myself, I rarely have more than 1 or 2 uploads going. Forcing Client mode didn't help (see 2nd problem, below).

2nd. Disabling Leaf mode doesn't recreate normal Client mode, e.g. you're still limited to one connection.

As a further question:
I assume that Ultrapeers cache the file-list of all clients, both Leafs and Clients. How does it learn of changes? Does it cache the sub-directory name, e.g. \Star Trek\ ?

If you added some kind of client-cache diagnostics, we could try to figure it out. I suspect there's some major bug floating around in the code that you haven't realized yet. If I had more time (and programming experience) I'd gladly dig into myself, but my time is better spent beta testing. Sorry!

crohrs December 28th, 2001 07:38 AM

sdsalsero: thanks for the feedback. I don't think this has anything to do with ultrapeers dropping upload requests, since all non-push uploads are done strictly peer-to-peer. Also, directory names are conveyed in the leaf to ultrapeer route tables.

What's happening, I think, is that leaf nodes are being removed one more hop from the "core" of the network, so they're getting fewer queries. This also explains why leaves are getting fewer replies. To solve these problems, LimeWire 2.0.3 ultrapeers will ignore TTL's when communicating with leaves, at least in some situations. Also, we will ensure that ultrapeers are better connected to the network by enforcing higher TTLs on them.

Disabling ultrapeer mode does not disable leaf mode. LimeWire considers leaf mode a Good Thing and tries to do it whenever possible. There is currently no way to force LW to be a non-ultrapeer without being a leaf. You can force LW to be an ultrapeer without being a leaf.

sdsalsero December 28th, 2001 09:17 PM

You say you cannot force normal mode, only Ultrapeer. Well, when I made the two changes to my Limewire.props file that had been suggested, I still seemed to be in Leaf mode (as you're now saying) because I only had one connection. The only difference was a cosmetic one -- my own host was labeled "Client" instead of "Leaf" (this being the label at the bottom left of the Connections screen).

When will v2.03 come out?

anti-bearshare December 29th, 2001 07:44 AM

With 1.9+ there is not a "normal" mode. The whole reason of implementing Ultrapeers technology was to decrease gnutella network traffic for hosts. Now you're either a "leaf" or an "ultrapeer". It will take time before Ultrapeer-hosts will have a large amount of other ultrapeers inter-connected to each other. But I am starting to see Ultrapeers with greater than 2 other ultrapeers inter-connected more often, so that is a good sign. As when 1.9 beta came out, you only saw 1 ultrapeer and that was the one you were connected to. It will just take be patient. You must remember the reason you're not getting a lot of results is b/c not a lot of people are running the versions (greater than) >1.9 as oppose to 1.8 (normal mode) and earlier. You also must realize the ultrapeer technology is no where near mainstream yet. There are still a few nicks and grannys that must be worked out; Vincent said something about implementing it into BearShare too.

All times are GMT -7. The time now is 09:33 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.0 ©2011, Crawlability, Inc.

Copyright 2020 Gnutella Forums.
All Rights Reserved.