Gnutella Forums

Gnutella Forums (http://www.gnutellaforums.com/)
-   Other LimeWire clone versions (http://www.gnutellaforums.com/other-limewire-clone-versions/)
-   -   Cabos won't start (http://www.gnutellaforums.com/other-limewire-clone-versions/103577-cabos-wont-start.html)

deanpark August 6th, 2016 05:12 PM

Cabos won't start
 
Hi;
I'm new to this forum and hope I've gotten on a proper thread. I've used Cabos for quite a few years and it works fine on my old computer, but not on a new computer I just purchased.

Both computers run Windows 10 home 64 bit
Both computers are behind the same router and firewall
Both use version 0.8.2
High speed cable 100meg+
Running Java 7 64 bit new computer
Running Java 8 64 bit old computer
Both have 8gb main memory


The first computer works fine on Cabos, starting and connecting.
The second won't start at all, nothing.

Can anyone help? I would also be willing to change to a different client if that would work better.

Thanks very much.

Dean Park
Saint Louis, MO
Moderator Edit: email removed for privacy protection from email spam, etc.

Lord of the Rings August 7th, 2016 01:43 AM

The latest Windows I have is Win 8 so I can't check for Win 10 issues and compatibility.

The fact you have one working on Win 10 already suggests it's obviously not necessarily a Win 10 issue. Have you considered updating your java 7 to 8 on the new computer? Java 8 is less buggy.

Try these things:

1. Sometimes the issue is java related. Uninstalling java, then re-installing java specifically using the 'Offline' java installer has often in the past fixed many issues. The 'Offline' installer is much larger and incorporates all data required within the installer itself instead of downloading the data during the installation process. This is the most reliable way to install java. The size of the installer is over 50 MB. Carefully check the installer options, they normally want to install unnecessary 3rd party junkware which you can opt out of. https://java.com/en/download/manual.jsp
~ Might be wise to also set the Java installer to 'Run as Administrator'.

If that does not fix the issue then:

2. Try changing the Cabos program properties permissions to 'Run as Administrator'.
If that has no effect, try:
3. Change the Cabos compatibility mode to an earlier Windows version.


(Off-topic: I haven't been able to run Cabos on MacOSX for several years. So I instead point people to Acqlite to use instead which is an OSX only equivalent. (Acqlite is a nicer program IMHO in any case.))

deanpark August 7th, 2016 08:56 AM

Thanks for the quick and detailed reply. As recommended, I uninstalled Java 7 and loaded the offline version of Java 8, but no improvement.

I attempted to 'run as administrator', also with no improvement.

Finally, I ran in compatibility mode (winXP) with the same result. I also tried every permutation of the above suggestions.

I forgot to mention in my original post that I had applied the Cabos ConnectFix 18 July 2016 before contacting the forum.

So far, no joy. I appreciate your help and if you have any other suggestions or alternate clients for Windows OS, I'd love to hear them.

Again, thanks.
Dean Park

Lord of the Rings August 7th, 2016 09:40 AM

I presume Cabos is allowed within the firewall's allowed programs?

What's the hardware (or software) differences between your two computers?

I am starting to wonder if you have a security software such as a 3rd party firewall, virus or other security software that might be blocking Cabos from being allowed to launch.

3rd party security software is often packaged within other software installers or even the computer itself upon purchase.

1. Try uninstalling and then re-installing Cabos, this time with Admin permissions (that appears to make a difference with some lime code based programs run on systems greater than Win XP.)

2. Set up a temporary alternative account on computer and see if Cabos runs from there. You might also (at a later point) try setting the account to admin permissions, re-logging in after doing so to refresh the account permissions.

Sorry if this seems like a lot of things to try, but your problem might also affect someone else so if we can find a solution then it's good for all.

deanpark August 7th, 2016 07:00 PM

Thanks, once again, for your suggestions. I verified that there are no software firewalls enabled on either computer. They are behind a hardware firewall and since Cabos works on the other computer, it can't be the firewall. The computers do use differing anti-virus software, so I turned off windows defender on the new one. I uninstalled and re-installed Cabos and ran with administrator privileges [although my user name is an administrator]. Also, the other computer [the one that works on Cabos], runs Cabos without administrator privileges and without compatibility mode.

There should't be any software differences between the computers; same version of the OS. However, they differ significantly on hardware. The older computer is a standard Gateway PC tower with 8g of memory and a 1T hard drive. The new one is an Acer clone of the Surface Pro 4 - Intel i7, 8g, 512g.

Finally, I tried setting up a temporary account with the settings you suggested. After all of that, Cabos still won't launch.

I assume most of these clients have similar coding. Might another one be more successful or, perhaps, should I just be happy that it works on one of them? I think I've bothered you enough.

Thanks,
Dean

Lord of the Rings August 7th, 2016 08:59 PM

Often a corrupt java installation is a reason a program won't run. But you've reinstalled appropriately so it looks like this is not the problem. No 3rd party security apps identified as preventing Cabos launching. So it might be easier to try another app as you suggested.

The better options of other programs to try would be:
WireShare or GTK-Gnutella or Phex or FrostWire.
WireShare is a follow-on of LimeWire Pirate Edition; though its technology is presently walking in circles between 2005 and 2010. GTK-G' is still being actively developed & is the most advanced gnutella program on the network. GTK-G' is not the most intuitive program to use for new users however. Phex has not been worked upon since 2009 and FrostWire since 2011.

Phex was probably the first gnutella client I tried back in 2002 but I found LimeWire more intuitive to use. Phex is lighter-weight than WireShare but does tend to result in more bandwidth overhead - but only if running as an ultrapeer. FrostWire is also slightly lighter in weight than WireShare as far as computer cpu & memory demands go. All these programs require java with the exception of GTK-Gnutella which is written in C++.

Note: If you wish to try Phex it might even be a good idea to get in contact with h4x5h17 via private message because he has compiled his own updated version of Phex.

Lord of the Rings August 8th, 2016 09:01 PM

I've had a re-think about your Cabos problem and why it works on one Win 10 and not the other. Presumably your older computer inherited the same permissions when upgrading to Windows 10. There might be a new security feature in Windows 10 that affects unknown apps. MacOSX has had something similar for the past 5 years, where 3rd party developers need to pay a fee & have their app go through a licensing process for their app to be recognised automatically by the system as being a safe app to open.
Another aspect to this is if the original program hash changes to that of what the system has recorded for it. This could have changed if you updated the Cabos hostiles file which is stored within the Cabos application folder.

Googling the problem I came across Windows 10 Apps Won't Open: Full Guide to Fix (ignore the sub-link advertisements at beginning & sides of the article.) I would recommend you consider backups, etc. before you try anything like this, if you consider it that is.

Other findings: http://winsupersite.com/windows-10/f...-splash-screen

https://support.microsoft.com/en-us/kb/2798317

https://social.technet.microsoft.com...iew2014General

deanpark August 8th, 2016 09:02 PM

Cabos fails to start
 
I installed WireShare. It worked the first time I tried it. I just have to accept a bit of a learning curve in using it.

Thanks for your help and patience. I appreciate you.

Dean Park

Lord of the Rings August 8th, 2016 09:17 PM

Quote:

Originally Posted by deanpark (Post 377460)
I installed WireShare. It worked the first time I tried it. I just have to accept a bit of a learning curve in using it. ...

Check the red Stickies here Getting Started Using LimeWire + WireShare to give you some idea.


All times are GMT -7. The time now is 12:19 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.0 ©2011, Crawlability, Inc.

Copyright 2020 Gnutella Forums.
All Rights Reserved.