View Single Post
  #1 (permalink)  
Old November 29th, 2005
snayit snayit is offline
Join Date: November 29th, 2005
Posts: 43
snayit is flying high
Default Newbie problem: queryHit not recognized by LimeWire

Hi guy,
I wrote a small program that connects to an ultrapeer and receives a certain query message with queryHit message. I'm testing my thingy vs. gtk-gnutella (works fine, even downloading a file from myself) and vs. LimeWire.
The problem is that LimeWire won't even show the queryHit i've sent in it's GUI (while gtk-gnutella does). I thought maybe it's because i'm not sending a urn, so i did - but still no luck. I'm not sending the other extra (QHD, i think). Than i thought it might be something with the TTL and HOPS - but i tried changing values and still it didn't work.
I am connecting both my LimeWire and my small client to the same ultrapper, thus getting the query i'm sending and sending back queryHit (obviously a wrong one, since it's not displayed in the GUI).
Following are the details, please help me understand what's wrong with me (besides the obvious, of course).

Query (that limewire sent my small client after i hit the search button):
payload (query)
TTL - 2
Hops - 1
Length - 27
Min Speed - 132
Search - aaa bbb ccc ddd eee

queryHit (that my small client sends back and LimeWire doesn't show as a result but gtk-gnutella does):
GUID (same one as from query)
payload (queryHit)
TTL - 4
Hops - 0 (i guess i'm wrong here or in the TTL but i tried few things)
count - 1
port (my prog's port)
ip (my prog's ip)
speed - 260
index - 963 (rand)
size - size (of a file i'm testing with)
name - aaa bbb ccc ddd eee (exact as in the query)
extra - urn:sha1:"urn i made up"
Servent ID - i made up but i'm consistent

Regards (and thanks in advance),
Reply With Quote