View Single Post
  #1 (permalink)  
Old January 24th, 2009
BCOOL's Avatar
BCOOL BCOOL is offline
Join Date: March 6th, 2007
Location: Honolulu Hawaii
Posts: 34
BCOOL is flying high
Default Is There A Problem With The Gnutella Network

Howz It Guys,

I posted this yesterday in the Limewire forum but I think it is more appropriate here so let me try again

You may have noticed a real increase of people complaining about little or no search results.I to have been having this problem.It started about three weeks ago.I now get two or three returns,or none,for mp3s from artists that a few weeks ago returned hundreds.I am also having the very same problem with Frostwire that worked great a few weeks ago...I've tried all the suggested fixes on the forum but nothing has worked.I've been watching this matter closely here on the forum and it seems the fixes offered are not working for anyone else either.

My question is this,could there be something wrong with the Gnutella Network itself?...I've noticed a increase in spam and trojans lately as well. Could that be causing the problem?...Something strange is going on here and I don't think the problem is with the Limewire software...

Is there someone that does maintenance on the Gnutella Network and can they be notified that there may be a problem?...Mahalo for any feedback.


Lord of the Rings wrote this...Gnutella network is a little complex. For example, FW & LW are set to only connect to versions 4.14 & higher (at least for uploading & I think for connecting also.) That leaves a lot of users with older versions that are being left out in the cold only connecting to each other. That reduces the size of the network for both FW & LW by splitting it perhaps in half.

There's more older versions out there than the programmers perhaps realise. eg: some people are unable to update/upgrade due to running older computers incapable of using the newer Java versions. Mac is a good example. Mac OS 9 users limited to using LW 4.0. OSX 10.0-1 users are limited to LW 4.08, OSX 10.2-3 users limited to LW 4.12.15. When LW 5 is released, OSX 10.4 users will be limited to using 4.18. Mac OSX most recent version is 10.5 which has Java 6 (1.6). Likewise Windows 98 & NT users are limited to the Java they can use.

The issue of lack of search results is something I've experienced myself. It is usually only a temporary problem lasting from 1-3 days or so. Whether this is due to spammers is an arguable point, such as by crowding/flooding the network. There are spammers who run as ultrapeers who people connect to ... either directly or indirectly via searching. eg: last night I suddenly was not getting search results .. only spam. I removed each of my ultrapeers one by one .. eventually started getting search results again.

How to control spammers? Use of the blacklist helps. Phex has these built into the program I believe. LW 5 also has these built in but optional to use via settings.

One thing I was informed about is if you repeatedly use the same search criteria over & over, that may result in having your searches temporarily anulled by your ultrapeers. You then need to wait for a new ip address, else wait some days.

I think this topic is perhaps even worth being in the General Gnutella Network Discussion section. Does this issue affect only LimeWire & FrostWire users? I've noticed similar issues with Phex but not sure it's identical. Phex connects to more ultrapeers for a start.

Reply With Quote