View Single Post
  #1 (permalink)  
Old June 13th, 2002
xyz's Avatar
xyz xyz is offline
Join Date: February 15th, 2002
Posts: 19
xyz is flying high
Unhappy Help! I must have broken something...

I'm using Phex 0.7.1 (executable) for JRE 1.4 in windows 98.

Phex was running fine the other day when I last closed it.

I tried running it again yesterday and it didn't work anymore- the splash screen would come up... and stay up, without doing anything else.

I didn't know what to do, so I tried reinstalling Phex; it made no difference. I then tried reinstalling JAVA; that didn't work either.

Finally I ran Phex_debug.exe
Here is what it said:

Version major.minor.micro = 1.4.0
JRE path is C:\Program Files\Java\j2re1.4.0_01
No 'hotspot' JVM at 'C:\Program Files\Java\j2re1.4.0_01\bin\hotspot\jvm.dll'.
JVM path is C:\Program Files\Java\j2re1.4.0_01\bin\client\jvm.dll
JavaVM args:
version 0x00010002, ignoreUnrecognized is JNI_FALSE, nOptions is 1
option[ 0] = '-Djava.class.path=phex.jar'
Main-Class is 'phex.f'
Apps' argc is 0
java.lang.IllegalArgumentException: moveColumn() - Index out of range
at javax.swing.table.DefaultTableColumnModel.moveColu mn(Unknown Source)
at phex.gui.models.FWTableColumnModel.addColumn(Unkno wn Source)
at phex.gui.models.FWTableColumnModel.buildColumnFrom XML(Unknown Source)
at phex.gui.models.FWTableColumnModel.buildColumnForC olumnID(Unknown Source)
at phex.gui.models.FWTableColumnModel.<init>(Unknown Source)
at phex.gui.tabs.MonitorTab.buildPassiveSearchTableCo lumnModel(Unknown Source)
at phex.gui.tabs.MonitorTab.initComponent(Unknown Source)
at phex.MainFrame.setupComponents(Unknown Source)
at phex.MainFrame.<init>(Unknown Source)
at phex.gui.common.GUIRegistry.initialize(Unknown Source)
at phex.f.main(Unknown Source)

Please tell me what to do to make Phex work again...
Reply With Quote