Gnutella Forums

Gnutella Forums (http://www.gnutellaforums.com/)
-   Other LimeWire clone versions (http://www.gnutellaforums.com/other-limewire-clone-versions/)
-   -   LimeWire mods (http://www.gnutellaforums.com/other-limewire-clone-versions/103348-limewire-mods.html)

ale5000 December 12th, 2015 10:46 AM

LimeWire mods
 
Can someone please say what are good and what are bad mods?

Lord of the Rings December 12th, 2015 05:46 PM

I find the question is a little vague. Can you expand on what you mean?

With exception of LuckyWire which was an early LW 5 clone, and Acqlite & Cabos which were very early LW clones, all the others listed are based off LW version 4 or earlier. Some were commercial or shareware versions.

It appears all the LW4 style clones use technology prior to LW 4.14 since none of the LW 4 clones incorporated DHT, TCL or UHC support. I am aware that despite all either going quiet or stopping development over the past 5 years, at least a couple have released updates in recent years. I've absolutely no idea what changes they have made. It appears they have not updated their built-in GWC lists (all are out of date.) This is probably why you don't see many of them listed on the GWC's now. (In theory, they should be able to learn new GWC's but perhaps that code was not incorporated. Their failure to implement such code might have been for security reasons because rogue GWC's existed last decade.)

I did try contacting at least one of their developer teams (a year or two ago) but received no response(s).

IMHO most of the LW4 style clones appeared to be roughly the same. Addax, CitrixWire & DexterWire all appear to have a marginally differently compiled GUI & all have such similar simplistic logo icons it appeared to be obvious they were all designed by same person(s). They do have a notable difference in some of the setting files compared to the other LW4 clones.

The earliest LW 4 clone I personally became aware of was LemonWire & other LW 4 style clones started up in the following years.

Several of the LW 4 style clones appear to have the same type of installer made by same people with the same junkware options. You need to be careful to uncheck all options except the agreement.

The very worst program I tried was LimeZilla. The early version was fine. But after an update message I updated. The installer forces certain junkware to be installed. LimeZilla checks at startup to see if one of the items exists, if not it won't open. Also, the LimeZilla help menu has a large number of web-links. All those links I tried made my browser & security software send me alarms of not to be trusted messages or/and automatically blocked.

runt66 has probably had plenty of experience with several LW4 clones & might know more.

ale5000 December 12th, 2015 06:50 PM

What I want to know is if there are mods that are bad for the network and should be blocked.
Also if one force bad software maybe I should block it.

Lord of the Rings December 12th, 2015 07:24 PM

Quote:

Originally Posted by ale5000 (Post 377016)
What I want to know is if there are mods that are bad for the network and should be blocked.

Not as far as I am personally aware of. Pity none of the old guard & devs are not still around. They would investigate new versions of software to check their behaviour was ok & not damaging to the network. et voilą was one of those who would do that. He was probably considered a troll by the ShareAza forums but he had genuine concerns about certain behaviour of certain versions of software as such. et voilą was originally a LW contributor & also one of the original FW devs, as well as being a SM here at GF.

App blocking can be achieved at program level; blacklisted versions for example.

ale5000 December 12th, 2015 08:35 PM

I already block some old versions and many fake versions in my GWC, I just wanted to know if there is a particular mod that need to be banned.

A lot of different mods do query my GWC although really rarely.

Lord of the Rings December 12th, 2015 08:59 PM

1 Attachment(s)
Well, there's the LW 5.1.2 version which was used heavily for spamming some years ago. They seemed to mostly disappear. I noticed recently I was connected to two at same time with same ip address. Then when I checked my logs since early in the year realised they've been connecting fairly often but in very small numbers. Their ips are so highly dynamic it's not worth blocking at hostile file level. UK & Portugal appear to be the two main places they appear to operate from (or using such ip's at least.)

I cannot imagine any normal person using LW 5.1.2. It was so basic and buggy. At GF we believed LW.org should not have released LW 5 until 5.3; even 5.2 version was still buggy though greatly improved. We believed LW.org were using normal people as beta testers for a program that was not up to scratch. I guess their continual financial income was at stake.

I did not bring this to your attention earlier because I didn't think LW 5.1.2 would apply to you. LW 5 was not wired to utilize GWC's.

Here's two very old samples: Sample 1 and Sample 2.

An edited connection log attached for past 6 months. There's a chance there's more of them out there but I was using the Light-Hostiles (NJ) which might have been blocking them out.

runt66 December 12th, 2015 09:59 PM

Be very careful with later versions of winmx , ; 5 and 6 from memory were full of nasty adware and malware ; the early versions of all these clones may , repeat may , be safer ;

runt66 December 12th, 2015 10:05 PM

You need to be careful to uncheck all options except the agreement.

WE CAN ONLY REPEAT THIS AGAIN AND AGAIN ;

runt66 December 12th, 2015 10:17 PM

THE installer forces certain junkware to be installed ;

AND THIS IS THE BIG PROBLEM AS STATED IN MESSAGE 2 OF THIS THREAD ;

Lord of the Rings December 13th, 2015 10:09 PM

1 Attachment(s)
Quote:

Originally Posted by Lord of the Rings (Post 377019)
Well, there's the LW 5.1.2 version which was used heavily for spamming some years ago.... I did not bring this to your attention earlier because I didn't think LW 5.1.2 would apply to you. LW 5 was not wired to utilize GWC's.

A check at 4 Octets Networking Solutions - GWEB Service 5 minutes ago (near bottom of listing) just proved my assumption to be incorrect.

Attachment 6866 <- snapshot of 5.1.2 @ the UK GWC.

It might be worth adding this version to the GWC version block after all.


All times are GMT -7. The time now is 09:11 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.0 ©2011, Crawlability, Inc.

Copyright © 2020 Gnutella Forums.
All Rights Reserved.