Gnutella Forums

Gnutella Forums (http://www.gnutellaforums.com/)
-   Getting Started Using LimeWire + WireShare (http://www.gnutellaforums.com/getting-started-using-limewire-wireshare/)
-   -   WireShare (formerly entitled LimeWire Pirate Edition) (http://www.gnutellaforums.com/getting-started-using-limewire-wireshare/102701-wireshare-formerly-entitled-limewire-pirate-edition.html)

Lord of the Rings July 6th, 2014 08:32 AM

Either only one person is sharing the file or else, others sharing it have all their upload slots busy. Or perhaps other persons who share the file are offline at the time. People not sharing what they download is a user population issue. Nobody can force anybody to share files. It's a user choice & starts at one. ;)

onnz423 July 6th, 2014 08:51 AM

Quote:

Originally Posted by Lord of the Rings (Post 375959)
Either only one person is sharing the file or else, others sharing it have all their upload slots busy. Or perhaps other persons who share the file are offline at the time. People not sharing what they download is a user population issue. Nobody can force anybody to share files. ;)

This is much slower than torrents. I remember when i saw many hundreds of sharers for one file in the network :sos:

Lord of the Rings July 7th, 2014 09:16 PM

Re-searching & get more results tool can often help to get more sources for a particular file. But again, it depends on how many persons are sharing the same file. Also, some files are shared by ShareAza users who have a history of only allocating very low bandwidth toward gnutella network. Always exceptions.

So try the re-search option & also use the 'Get More Results' or 'Find More Sources' option by right-clicking the search tab a couple minutes after the search finishes. Repeat once or twice, then leave it for an hour or two before trying again. Don't do this too often for the same search criteria. Another thing to try is using a different search criteria which is similar to the one you used to find the file in the first place. That can take some imagination. For example, if it's music, try searching just the title of a song instead of the artist or vice-versa, perhaps not the same song you're after. This will help bring in more host results sharing similar files & help to extend your search across the network.

Torrents do have a lot of advantages over the gnutella network or similar networks. People are more likely to allow partial file sharing with torrents which speeds up the downloads for everyone & means much less work needed by the seeders (sharers) of the complete file.
I've had situations like uploading same video file to a few hosts at same time & was obvious at least a couple of them had partial file sharing disabled. So I was expected to upload the file individually to each one by myself. Those who disable partial file sharing make it somewhat harder & unfair on everyone else. If all 3 or 4 of the downloaders had partial file-sharing enabled, they would have downloaded the large file in 10-25% of the time.

GeX August 20th, 2014 11:54 AM

WireShare has encountered an internal error
 
I get the error:

"WireShare has encountered an internal error. It is possible for WireShare to recover and continue running normally. To continue using WireShare, close this window. If desired, you can click 'Show Bug' to look at the information about the error."

It keeps on showing for ever.

As described on page 38 of this thread (LimeWire Pirate Edition):
http://www.gnutellaforums.com/gettin...dition-38.html

I have the latest versions installed: WireShare 5.6.4.1, Java 7 update 67, Mac with OS X 10.9.4 (Mavericks).

How to fix it?
Thanks.

Lord of the Rings August 20th, 2014 12:51 PM

If it happens again, can you click the Show Bug information button & copy about the first 50-80 lines, that's the most important part. Then post that part in a reply to this post thread. You can post it inside a code bracket. Each report can be a little different due to a different cause & that's what we need we need to find what the cause is.

When you open WireShare, under the WireShare menu > About WireShare, does it say Java 7 or Java 6?

How many incomplete downloads do you have?
How many files are you sharing?
How many files are listed in your library?

When you said the problem was similar to the problem on the page you pointed to, does the program create a folder called .wireshare or .limewire anywhere?

For MacOSX it might be a memory issue. This is something BigJx & I need to sort out. MacOSX's memory use-age is larger than the Windows version uses. If you were using LPE it would probably be worse.

GeX August 20th, 2014 02:52 PM

Thanks for the quick reply.

Such error window shows every single time that I open WireShare. In fact, it keeps on showing all the time (up to four stacked error windows). And if I close them all manually, they show again.

WireShare - About WireShare says:
WireShare 5.6.4.1
Java 1.6.0_65

That is amazing to me, since Apple - System Preferences - Java - Update says Java 7 update 67.

Do I have them both Java 6 & 7 installed? How to remove the oldest one?

I do not have incomplete downloads inside
/Users/~/WireShare/Incomplete
or
/Users/~/WireShare/Saved

I have no files in
My Files - Public Shared (top left of WireShare main window)

I have no files in my Library (top left of WireShare main window)

The folder
/Users/~/WireShare
does not contain
.wireshare
or
.limewire
browsing it with Macintosh Explorer which shows invisible items. It contains only two visible folders:
Incomplete
and
Saved

My Mac mini has 16 GB RAM with plenty of free memory. 1TB Fusion drive with 600 GB free space.

I tried Limewire Pirate Edition time ago, yet could not get it connected after months, so I gave up. I previously used it without problema and Limewire before that without problem either. But that was years ago with other Macs and older operating systems...

The Show Bug says as indicated below:

Code:

WireShare version 5.6.4.1
Java version 1.6.0_65 from Apple Inc.
Mac OS X v. 10.9.4 on i386
Free/total memory: 88973544/132579328

java.lang.NoSuchMethodError: org.apache.commons.logging.Log.info(Ljava/lang/Object;Ljava/lang/Throwable;)V
        at com.limegroup.gnutella.HostCatcher.read(HostCatcher.java:580)
        at com.limegroup.gnutella.HostCatcher.read(HostCatcher.java:523)
        at com.limegroup.gnutella.HostCatcher.connect(HostCatcher.java:407)
        at com.limegroup.gnutella.ConnectionManagerImpl.connect(ConnectionManagerImpl.java:1573)
        at com.limegroup.gnutella.ConnectionServicesImpl.connect(ConnectionServicesImpl.java:158)
        at com.limegroup.gnutella.CoreRandomGlue$2.start(CoreRandomGlue.java:100)
        at org.limewire.lifecycle.ServiceRegistryImpl$ServiceHolder$AnnotatedService.start(ServiceRegistryImpl.java:219)
        at org.limewire.lifecycle.ServiceRegistryImpl$ServiceHolder.start(ServiceRegistryImpl.java:172)
        at org.limewire.lifecycle.ServiceRegistryImpl.startStage(ServiceRegistryImpl.java:92)
        at org.limewire.lifecycle.ServiceRegistryImpl.start(ServiceRegistryImpl.java:80)
        at com.limegroup.gnutella.LifecycleManagerImpl.doStart(LifecycleManagerImpl.java:153)
        at com.limegroup.gnutella.LifecycleManagerImpl.start(LifecycleManagerImpl.java:127)
        at org.limewire.ui.swing.Initializer.startCore(Initializer.java:533)
        at org.limewire.ui.swing.Initializer.initialize(Initializer.java:170)
        at org.limewire.ui.swing.GuiLoader.load(GuiLoader.java:44)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at org.limewire.ui.swing.Main.main(Main.java:87)


Detail: Uncaught thread error: main

-- listing session information --
Current thread: main
Active Threads: 31
Uptime: 0:02
Is Connected: false
Number of Ultrapeer -> Ultrapeer Connections: 0
Number of Ultrapeer -> Leaf Connections: 0
Number of Leaf -> Ultrapeer Connections: 0
Number of Old Connections: 0
Acting as Ultrapeer: false
Acting as Shielded Leaf: false
Number of Active Uploads: 0
Number of Queued Uploads: 0
Number of Active Managed Downloads: 0
Number of Active HTTP Downloaders: 0
Number of Waiting Downloads: 0
Received incoming this session: false
Number of Managed Files: 0
Number of Mounted Friend Files: 0
Number of Shared Files: 0
Guess Capable: false
Received Solicited UDP: false
Port Stable: true
FWT Capable: false
Last Reported Port: 17487
External Port: 17487
IP Pongs Received: 0
Number of Content Response URNs:
Number of CreationTimeCache URNs: 0
VF Byte Cache Size: 0
VF Verify Cache Size: 0
VF Queue Size: 0
ByteBuffer Cache Size: 31
Number of Waiting Sockets: 0
Number of Pending Timeouts: 0
Peak Number of Thread: 36
Number of SP2 Workarounds: 0
System Load Avg: 1.4736328125
Objects Pending GC: 0
Free Space In Settings: 586367594496
Free Space In Incomplete: 586367594496
Free Space In Downloads: 586367594496
Heap Memory Usage: init = 134217728(131072K) used = 36542256(35685K) committed = 132579328(129472K) max = 530186240(517760K)
Non-Heap Memory Usage: init = 268603392(262308K) used = 45924112(44847K) committed = 271323136(264964K) max = 301989888(294912K)
SlotManager dump:: active:0:0 1:0 2:0 queued:0:0 1:0 2:0 resumable:0:0 1:0 2:0 bw now:0.0 session avg:0.0
Number of select calls: 8
Number of immediate selects: 0
Average time in select: 325009873

-- listing threads --
JmDNS.RecordReaper: 1
AWT-AppKit: 1
CreationTimeCacheDeserializer: 1
ServiceRegistry-start-id db store: 1
IconLoader: 1
QRPPropagator: 1
QueryUnicaster: 1
Thread-6: 1
FirewallEventThread: 1
DAAPQUEUE: 1
DHT-Executor: 1
process reaper: 1
UDPSocketChannelConnectionEvent: 1
NIODispatcher: 1
Message-Executor: 1
ServiceRegistry-start-DAAP: 1
AWT-Shutdown: 1
JmDNS.SocketListener: 1
SwingWorker-pool-1122818-thread-1: 1
device search response: 1
Deadlock Detection Thread: 1
backgroundExecutor: 1
NetworkManagerImpl.testTLS: 1
main: 1
HttpClient pool: 1
AWT-EventQueue-0: 1
Library Disk I/O Thread: 1
MulticastService: 1
IdleThread: 2
Image Fetcher 3: 1


-- listing properties --
AVERAGE_CONNECTION_TIME=165314
NEXT_URN_BLACKLIST_UPDATE=1409552048953
FRACTIONAL_UPTIME=0.0012078815
LAST_EXPIRE_TIME=1407955436342
SESSIONS=6
TOTAL_CONNECTION_TIME=826570
CLIENT_ID=287637DA5682F4C15E1A737EC4FE6D00
LAST_SHUTDOWN_TIME=1408560336369
DHT_NODE_ID=A07820B51234035743222DE594887162A7066B13
DHT_MODE=PASSIVE_LEAF
CURRENTLY_RUNNING=true
UPTIME_HISTORY=309;278;175;46;27
HANDLE_TORRENTS=false
LIBRARY_VERSION=FIVE_0_0
LAST_URN_BLACKLIST_UPDATE=1408569682403
HANDLE_MAGNETS=false
POSITIONS_SET=true
WINDOW_X_V5=288
TOTAL_UPTIME=835
PORT=17487
AVERAGE_UPTIME=167
WINDOW_Y_V5=137
TOTAL_CONNECTIONS=5
DOWNTIME_HISTORY=86400;90;3611;55167;545190;9345
LAST_FWT_STATE=true
TLS_WORKED_LAST_TIME=true

Should you need further information, just let me know.

Many thanks again for your kind help!

Lord of the Rings August 21st, 2014 03:01 AM

Thanks for posting your bug report, much appreciated. :)

Not sure if this will help but you can at least try it for now:
Go to Applications & find WireShare, Control (or Right) click & choose Get Info. Change the option from Run in 32-bit. If it's enabled then disable it or vice versa. See if this fixes the launching problem. (Here is a sample image using LW as an example.)

Another thing you could try is setting up a test account. This only takes a few minutes & can be easily deleted after use. See if WS opens ok in that account.

WireShare will default to using Java 6 if it exists, even if you have Java 7 installed. If Java 7 is the only java installed then it will use Java 7 or later.

Lord of the Rings August 21st, 2014 03:23 AM

Just had a crazy thought. If the above does not work then try this:
1. Delete the WireShare folder from your user preferences folder, try launching WS.
If that again fails then:
2. Delete the WireShare folder from your user preferences folder, try launching WS & set the language to English if the program does not crash before the setup stage, see if that makes any difference.

GeX August 21st, 2014 10:51 AM

Thanks for the replies.

I have tried the above to no avail. The problem is even more intense in 64-bit mode.

I have not tried a new account (I will try that later), but I have installed WireShare 5.6.4.1 on another Mac (iMac instead of Mac mini) with the same version of Mac OS X and Java and it works with both 32- and 64-bit mode. No problem there. Such iMac had on older LimeWire Pro 4.9.8 (that is of year 2007) installed, whereas in the Mac mini with the problem newer versions of LimeWire were installed through the years, and eventually the LimeWire Pirate Edition 5.6.2 (yet it did not open since many months ago), as indicated above.

There are probably remains on the Mac mini of LimeWire and LimeWire Pirate Edition. How to remove all files associated with them? Maybe that fixes the issue.

Thanks again.

GeX August 21st, 2014 11:37 AM

Just in case it is useful, I had installed over the years the following Gnutella clients in such Mac mini:

Acqlite
Acquisition
Cabos
FrostWire
LimeWire Pro
MactellaX_PPC
WireShare

Additionally, maybe removing Java 6 and leaving Java 7 could fix the problem. I wonder how to remove Java 6.


All times are GMT -7. The time now is 05:00 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.0 ©2011, Crawlability, Inc.

Copyright 2020 Gnutella Forums.
All Rights Reserved.