Gnutella Forums

Gnutella Forums (http://www.gnutellaforums.com/)
-   Getting Started Using LimeWire + WireShare (http://www.gnutellaforums.com/getting-started-using-limewire-wireshare/)
-   -   WireShare (formerly entitled LimeWire Pirate Edition) (http://www.gnutellaforums.com/getting-started-using-limewire-wireshare/102701-wireshare-formerly-entitled-limewire-pirate-edition.html)

GeX August 22nd, 2014 07:28 AM

Thanks. The connection bars at the bottom left corner of the screen show gray and Connecting for ever.

The Tools - Advanced Tools initially after starting LimeWire Pirate Edition shows many hosts Connecting, but none remains after a few seconds. The incoming searches and Console are also empty. Says nothing about firewall.

I have the Mac firewall and Little Snitch on, but have granted permission for LPE (none asked about WireShare and it does not show on the list of such firewalls).

I have always used manual private IP numbers. My public IP is dynamic. I have the router ports open and manual port setting in the application. In the past, LimeWire only connected with that.

In summary, I have many years of experience with Limewire without problem, but from some months ago, I cannot connect with Limewire and with WireShare as described below.

So I am lost. There is certainly something in Mac Mac preventing connections, but I wonder what is it and how to fix it.

Lord of the Rings August 22nd, 2014 08:04 AM

I'm starting to wonder if the problem is ISP related (your internet service provider.)

Could you try connecting with LPE with Little Snitch temporarily disabled whilst testing the connection, disabling it before opening LPE? I'd recommend adding a fresh connection file: OSX LW connection installer - MediaFire Mirror.

I wonder if any of your gnutella programs will connect. Perhaps try FrostWire v4.

I tried Little Snitch some years ago but due to my ignorance removed it because I found it too naggy & problematic for all the internet apps I use.

Lord of the Rings August 22nd, 2014 08:35 AM

It just occurred to me, you were not receiving any emails from the forum mail server. I'm wondering if this is somehow related. Somehow the emails were being blocked or filtered out from receiving them. It seemed odd you did not receive any of the test emails sent. The same tests worked for both Birdy & myself. Nobody else has reported registration issues in recent months in regards to not receiving the forum mailer's emails.
Also, you should have received email notifications for each post reply, so you are notified someone has replied to your posts.

Is there something bad about the word gnutella? :D

I don't suppose Little Snitch has anything to do with email right? Are you using a blocklist with Little Snitch?

I suspect Little Snitch can potentially change the system config files. There might be a change in there which is affecting things. From memory the config files are found in the /private/etc folder, but I might be wrong. Mavericks might be a little different.
Mavericks Gatekeeper might also be an issue.

I'm preferring to stick with Snow Leopard. I don't like having something else control what I wish to open. And the lack of keeping a folder open when opening a sub-folder would slow my work flow down incredibly. Though the work spaces option is good I admit. TextEdit's autosave feature is a PITA & ruined an xml project I was working on. Even the shortcut has changed for selecting multiple random individual files (2 keys instead of one for what should be such a simple task.) If OSX Yosemite doesn't rectify these & some other issues then I'll wait yet a few extra years before upgrading my MP. I get the impression Apple has employed lots of Windows users in its design teams, an OS I hate. lol :p

GeX August 22nd, 2014 12:46 PM

Thanks again for all the replies.

No problem with FrostWire 5.7.5. It connects turbo-charged in one second.

It is clear to me that this is something LimeWire-related and as said, I am experiencing this problem since many months or even years ago, when I updated its version at some point. And since WireShare is LimeWire-based, the issue remains. But I wonder what is it.

No problem with my ISP. It has no restrictions at all for sure. My email for gnutella forums is not related to my ISP. I think the problem there is related with hotmail.com blocking somehow emails from gnutella. I have no filters to block hotmail at all.

Little Snitch is the best firewall for Mac, but initially you have to let it know the accept/reject connections, which may be a bit tedious. Once done (a few minutes during the first days after installation), it runs in the background like a charm. Little Snitch has nothing to do with my email. I am not using a blocklist with Little Snitch. I will try later on to disable Little Snitch, but I guess that is not the problem, since the iMac in which WireShare works has the same configuration and works as said.

Mavericks Gatekeeper is disabled.

So, here we are.

Lord of the Rings August 22nd, 2014 04:20 PM

Quote:

Originally Posted by GeX (Post 376050)
No problem with FrostWire 5.7.5. It connects turbo-charged in one second.

FrostWire 5 does not use the gnutella network, it's a torrent only program. That's why I suggested FrostWire version 4. :)

Though the fact FW5 has no problems that can be seen is a good thing.

If you wanted to try FW4: FrostWire 4 versions although I think the FW site still hosts some FW4 versions.

Lord of the Rings August 22nd, 2014 05:37 PM

Quote:

Originally Posted by GeX (Post 376047)
I have the Mac firewall and Little Snitch on, but have granted permission for LPE (none asked about WireShare and it does not show on the list of such firewalls).

You might have needed to have manually added WS to the firewall(s) including Little Snitch.

(There is a command in the WS installer to auto-add WS to the OSX firewall, but perhaps something prevented this happening or else, it does not work on all systems.)

Quote:

Originally Posted by GeX (Post 376047)
I have always used manual private IP numbers. My public IP is dynamic. I have the router ports open and manual port setting in the application. In the past, LimeWire only connected with that.

So do you mean you port forwarded your router? Whichever port that is, then use that for LPE.

You said WireShare/LPE open fine on your other Mac (iMac?), but does it connect ok? If it's fully connected it should show 5 blue bars bottom left-corner of the program.

Have you tried the connection fix options suggested here http://www.gnutellaforums.com/connec...t-connect.html such as disabling DHT, TLS & Ultrapeer mode.

I remember my LW 4 versions on this computer would only connect with TLS disabled. As soon as I did LW would usually quickly connect as an ultrapeer. Obviously an issue related to my particular system.

(Thanks Birdy for the suggestions.)

As far as a particular program not working on a particular system, that happened to me a few years ago. Neither LW 4.18 or the early LW 5 versions would open on my main OSX. I could only run them on an different startup drive on same computer. I was not the only person who had this issue according to LW beta forum OSX discussions at the time. Then one day I realised the problem had mysteriously vanished (a year or two later.)

GeX August 23rd, 2014 03:38 AM

Thanks for all the support. I have installed the latest FrostWire 4 (4.21.8) for Mac, yet it does not open in OS X 10.9.4.

I have turned off both the Mac firewall and Little Snitch, yet the issues remain: LimeWire does not connect and WireShare does not connect and shows the pesky window ("WireShare has encountered an internal error").

I have deleted all rules for LimeWire on both firewalls, and when opening gain LimeWire, both firewalls ask for permission. Yet, there are no rules for WireShare on either firewall and they do not ask for permission ever about WireShare. Anyway, I have added WireShare to both firewalls granting permission to no avail. The issues remain.

Yes, I port forwarded the router, using such ports for LimeWire and WireShare to no avail. The issues remain, even using Universal Plug 'n' play (recommended).

The other Mac (iMac) works OK with WireShare as said, which means turbocharged (five blue bars) in a second. Both Macs are connected to the same router. I have FTTH (200 Mbps symmetrical connection).

Disabling all Ultrapeer, DHT and TLS does not fix the issues on LimeWire or WireShare.

Amazing. I wonder what is going on preventing LimeWire and WireShare connecting on the Mac mini.

GeX August 23rd, 2014 11:27 AM

The WireShare 5.6.4.1 (Java 1.6.0_65) on the iMac (OS X 10.9.4 Mavericks) with the default installation takes one minute to connect (turbo-charged with five green first to eventually blue bars).

It is set as 32-bit mode in the
Finder - Get Info
and has the
WireShare - Preferences - Advanced - Listening Ports
as
Gnutella port: 6346
Use Universal Plug 'n' Play (Recommended) SELECTED
Manual port forward: 6346 NOT selected
BitTorrents ports: 6881 to 6889
Use Universal Plug 'n' Play (Recommented) SELECTED

On the other hand, the
Tools - Advanced Tools
shows
Port 6346
and shows five connected servers eventually.

With the same configuration, WireShare on the Mac mini never connects (shows Connecting all the time with all the five bars gray) and takes a frustrating 20 minutes to check all servers at
Tools - Advanced Tools
and shows
Port 6346
on such window with no connected servers at all.

During such 20 minutes, up to three "WireShare has encountered a problem" pesky windows show (stacked one below the other). If you close them all manually, they show again for such 20 minutes. During that period you cannot select any menu or change any configuration until you close all and every of such pesky windows, and since they show again after two or three seconds once manually closed, it is almost IMPOSSIBLE to do anything during such 20 minutes (not even quitting WireShare, until you close such pesky windows, which is not easy since they reproduce after two to three seconds). REALLY FRUSTRATING. I think that such window is shown every time that
Tools - Advanced Tools
scans a new server with no connection, since after 20 minutes such scan stops and also the pesky window do not show again if manually closed. Update: it shows again (up to three stacked windows as well), but if you close them manually they do not show for 1 minute and 30 seconds (instead of two or three seconds as described above), so is less frustrating.

It would be great if such pesky window showed ONLY ONCE in future versions of WireShare, or at least did not block selecting menus, changing configurations, etc as now happens. As said this is the most frustrating part, besides not having connection, of course.

But there is something else which is weird. Even if I set the
Manual port forward: 6346
on the Mac mini, and later on I select
Use Universal Plug 'n' Play (Recommended)
when I close such window and open again or when I quit and open again WireShare, it has changed to
Manual port forward: 46189
even though it is not selected, because the
Use Universal Plug 'n' Play (Recommended)
is selected as said. So, it changes automatically from 6346 to 46189. I do not know if that gives some clue of what is going on, or if it is relevant at all, but that does not happen on the iMac where ShareWire works. Doing more testing it changed from 6346 to 50672 on both
Gnutella port
and
Manual port forward
even though the
Use Universal Plug 'n' Play (Recommended)
was selected. But remained as 6346 on
Tools - Advanced Tools
Just in case such information is useful.

As always, any idea will be most appreciated.

Lord of the Rings August 23rd, 2014 04:15 PM

I only use Mavericks for testing. On my Mavericks, FrostWire 4.21.8 & 5 won't open. From memory of couple months ago, FW5 crashes on startup. FW4.21 vanishes when trying to open. FW 4.20.9 opens fine however & connected quickly after I used the latest connection installer, turbo-charged after a minute. FW was stubborn to close however.
(I'll need to fix the launch option in the FW connection installer as this launched WS instead. I guess I'll revert to the previous technique i used from 2 years ago. Can't remember why I changed it, but seems to fix the issue. Multiple copies of FW on system was probably the reason. Mavericks won't let you move apps outside the app folder once it's actually there. Edit: created a script that only opens FW4, but can take notable amount of time to find right version if multiple internal HD's like mine; over 10 seconds. It refuses to open FW5.)

WS opens & connects quickly & is using Java 6. Both java 6 & 7 are installed on my Mavericks.

WireShare is listed as Java in the firewall. So check to see if your firewall(s) have java listed. I forgot about this aspect. Console also lists WS as java. (BTW Console will also list Phex as java.)

It might be an idea to reinstall Apple's Java 6 (1.6). Your original java installation might be corrupted. I know it's a large installation file but this is at least something you can try. A quick download link to Apple's OSX java 6 here.

I'm not sure why you are getting multiple error windows. I have seen this before but only after either LPE/WS ran out of memory overnight after a several day session. Normally you should only get a single error window popup, at least initially.

I think there was something else I was going to say but my computer crashed as I was replying to your posts (after a 2 week run & as I was launching Mountain Lion.)

We've at least ascertained the problem is only your MM computer. So something with the system is not liking java applications &/or not allowing them to connect.

Lord of the Rings August 23rd, 2014 04:37 PM

Here's a couple things you can try:

1. Go to your Applications folder, find WireShare. Control-click the program & choose Show Package Contents. Open Contents. Open the Info.plist file using TextEdit or similar program to be sure it is only saved as basic text only. About 3/4 way down find the line:
Code:

<key>JVMVersion</key>
    <string>1.6+</string>

Change the <string>1.6+</string> line to:

Code:

    <string>1.7+</string>
by simply changing the number 6 to a 7. Save the document. This will force WS to use Java 7 or later.

2. Keep the Contents folder of WS open. Open the Resources folder. Open Java folder, then lib folder. If you find a file called bootstrap in this lib folder, delete it. This file is normally deleted after the first run. But since your WS is not opening properly, it may still exist.

Thanks to BigJx for the 1st how-to & last suggestion.


All times are GMT -7. The time now is 05:08 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.0 ©2011, Crawlability, Inc.

Copyright 2020 Gnutella Forums.
All Rights Reserved.